TorchLite Guide Part 2 – Using the Molecule Editor

TorchLite is a powerful 3D molecular viewer capable of generating Cresset’s electrostatic and shape fields for standard molecule files (e.g.: .sdf, .mol2, etc.). The program is extremely flexible, allowing molecules to be entered manually, from smiles strings, 2D files, molecular drawings or created using our internal molecule editor. Once loaded into the program, any data in the original file(s) can be viewed and sorted together with calculated physical properties provided by TorchLite in a molecular spreadsheet. TorchLite has tools to enable download and interrogation of protein ligand complexes and has a simple minimization tool allowing the visualization of reasonable conformations derived from the original 2D input. Additionally, various 3D field displays are available with molecules editable showing ‘on-the-fly’ changes in the field visualizations.

Once you’ve mastered the basic steps for viewing molecules and their data (TorchLite Guide Part 1) try the following more advanced steps for editing your molecules.

To follow along, download TorchLite for free and load any .sdf or .mol2 file into the software. If you don’t have a molecule ready, try this project to get started with the TorchLite molecular editor.

  1. To get started simply load molecules using the ‘Open’ icon in the menu or click “File: Open” and browse to an appropriate file (e.g.: .sdf, .sd, .mol .mol2, etc.), which will then appear in both 2D and 3D format. Alternatively, click “Edit: Paste” to paste molecules from clipboard (eg .using copy paste from Chemdraw or Accelrys Discovery Studio)
  2. Left click on a molecule you want to edit in the 2D molecule window. Right click to open the menu and “Edit a copy” of the selected molecule to open the editor. Click and drag the bottom right of the editor window to enlarge the view.
  3. Look at the bottom right for instructions on how to manipulate the molecule. Break a bond by hovering over the bond and pressing delete on the keyboard (or you can also right click and select delete). You can undo any manipulations by pressing Ctrl-Z. Add a new atom by left clicking and dragging from an existing atom.
  4. You can select part of a molecule (eg. a section you created via the bond breakage) by hovering over it with the mouse and right clicking to reveal the context sensitive menu. This menu can be used to select and to manipulate this fragment independently. Alternatively, whilst holding Ctrl and left clicking on an atom, or moving the mouse to create a lasso, you can select any part of a molecule to edit.
  5. Bonds can be rotated by hovering over the bond of interest (which will highlight in magenta), left clicking and then moving the mouse to spin the smaller fragment. Holding shift and repeating the above will spin the larger fragment.
  6. Bond order can be changed by left clicking while hovering over a bond. This will increase the bond order and then cycle on subsequent clicks.
  7. Translation of molecules can be done by right clicking an atom and dragging. If a fragment or atom is selected this translates the selection relative to the non-selected independently.
  8. Clicking “Minimization” applies the minimizer to the molecule in the editor window and will find the local minimum energy of the structure. If fragments are selected (those highlighted in cyan) then the minimization only applies to that fragment. You can use this to keep a bioactive conformation rigid and minimize only the part you have changed.
  9. The “Charge for ph7” button will protonate basic functionality and deprotonate acidic functionality. Atom charge can be manually set by selecting an atom, right clicking to open the menu and selecting the desired charge. The “Add fields” button will re-calculate fields after an edit. Most of the display settings are the same as those in the main 3D window and are viewable in this editor.
  10. Changing chirality of a stereo center can be done by first using “Add H”. Use the labels dropdown menu (top menu bar) to select “Chirality”, then, select the H atom while right clicking and dragging through the stereo center. Minimize the selected stereo center and one of the connected groups by selecting this portion only. You should observe the label display the inverted chirality.
  11. Save the molecule back in to the main project and close the editor at any time. The new molecule this will then be selectable from the 2D window. Right click on the 2D window and select “Rename Molecule” or simply double click the “Title” cell to give your newly edited molecule a recognizable name. Compare back with the original molecule by pressing “Ctrl” and clicking on the original molecule. You can compare them next to each other (use the “Grid” button on the toolbar on the right) or overlaid.
  12. To create a completely new molecule from the 3D window, use “Edit” from the top menu and select “Create Molecule” which will open a blank editor. Click to place an atom or ring template which can then be manipulated further.

Still have questions about TorchLite? Contact us and we will be happy to help. Click here to view Part 1 of this guide, in which we give you tips for using the viewer.

TorchLite Guide Part 1 – Using the Viewer

TorchLite is a powerful 3D molecular viewer capable of generating Cresset’s electrostatic and shape fields for standard molecule files (e.g.: .sdf, .mol2, etc.). The program is extremely flexible, allowing molecules to be entered manually, from smiles strings, 2D files, molecular drawings or created using our internal molecule editor. Once loaded into the program, any data in the original file(s) can be viewed and sorted together with calculated physical properties provided by TorchLite in a molecular spreadsheet. TorchLite has tools to enable download and interrogation of protein ligand complexes and has a simple minimization tool allowing the visualization of reasonable conformations derived from the original 2D input. Additionally, various 3D field displays are available with molecules editable showing ‘on-the-fly’ changes in the field visualizations.

Once you’ve downloaded TorchLite, the following steps should help you get started with viewing your molecules.

See Part 2 of the Guide here.

  1. Install and double click the TorchLite icon to open an empty file.
  2. To get started simply load molecules using the ‘Open’ button and browse to add an appropriate file (.sdf, .sd, .mol, .mol2 etc), which will then appear in both 2D and 3D format. Alternatively, click ‘Edit: Paste’ to paste molecules from clipboard (e.g: using copy paste from Chemdraw or Accelrys Discovery Studio).
  3. If you try moving the mouse onto the 3D window, the bottom left panel tells you which mouse clicks will move the molecule in the 3D viewer.
  4. You can scroll through the 2D molecule window pane by left clicking or by using the green arrows below the 3D window. Right clicking on molecules in the table gives a context menu that operates on the molecule that was clicked (eg. copy, rename etc).
  5. Molecules can be selected by left clicking on the 2D panel. In the menu: “selected molecules” indicates that display options apply to the currently selected molecule. Display settings can be toggled by clicking icons in the top menu bar. Display settings can also be toggled to apply to all molecules using this dropdown option. Field points (4-types) can be toggled on and off independently.
  6. To view electrostatic surfaces, click the +ve or -ve icons to toggle surfaces – reducing the number increases the size of the field surface. Yellow surface fields usually require a smaller number (2.00) relative to the electrostatics (3.00-4.00) for a good view.
  7. To make multiple selections, hold shift or Ctrl before selecting from the 2D panel – this is particularly good if you make a copy of a compound and apply different visualizations to each – and visualize by toggling the grid icon (Right hand) panel. Hover the mouse over this panel to display the icon name.
  8. Hitting the ‘Delete’ key will delete all the selected molecules.
  9. To filter the molecule table, use the filters window (enabled with View->Windows), which holds all of the available filters. Choose any data column from the dropdown menu to apply filters using the sliders which appear upon column selection.
  10. To view protein-ligand complexes, open the .pdb complex using File->Open or download the .pdb file directly by specifying the .pdb code in File->Open PDB. The protein importer will open with the protein displayed in 3D and the chains and residues displayed in a table.
    1. Sort this table on “Structure” to find the ligand.
    2. Highlight it by clicking on its structure then click the “Use as Reference” button on the right hand side.
    3. Optionally choose to delete uninteresting or distal chains by selecting in the table and clicking “Delete”.
    4. Waters can be deleted with the “Delete waters” button.
  11. You can Export compounds as .sdf, .mol file etc using “File: Export”, or save the session as a torchV10 file (.fpj) using “File: Save Project”.

Still have questions about TorchLite? Contact us and we will be happy to help. Click here to view Part 2 of this guide, in which we give you tips for using the molecule editor.